tyFlow Forum
particle force "cant make circular reference" - Printable Version

+- tyFlow Forum (http://forum.tyflow.com)
+-- Forum: tyFlow Discussion (http://forum.tyflow.com/forum-1.html)
+--- Forum: General Discussion (http://forum.tyflow.com/forum-2.html)
+--- Thread: particle force "cant make circular reference" (/thread-136.html)



particle force "cant make circular reference" - super gnu - 04-04-2019

ive a simple grain sim.  im trying to use "particle force" to do an up-rezzed version. 

i made a copy of the flow, deleted most of the operators, leaving just the birth voxels operator and display operator..    increased the resolution. 

added a "particle force" operator after the birth operator, and tried to select the first flow as the source particles. 

i get "cant make circular reference" error. 


i tried duplicating the voxel source geometry in case they cannot share the same source geo..      same error.. 

i tried creating a fresh flow and just copying the birth voxel operator from original flow.. same error. 

i tried creating a fresh flow and all fresh operators..   same error. 



what am i doing wrong?


RE: particle force "cant make circular reference" - Fraine7 - 04-04-2019

You’ll need to add a second TyIcon and create your particle force in there. A completely different system will allow you to reference the first one and you shouldn’t get the circular reference anymore


RE: particle force "cant make circular reference" - super gnu - 04-04-2019

ok so that worked.   however i cannot get a decent result with the particle force for up rezzing. 

i have my low res grain sim falling at the start of the sim until it lands in a tray.  

the higher resolution duplicate linked to original via particle force (with force set to "replace"  ive also tried add and blend with worse results) 

kinda works.. the particles generally follow the source particles.   but tons and tons get left behind as they fall.   increasing the radius and falloff help, but i need them way higher than the suggested settings of 100% and 50% of source particle radius. 

i currently have them set to 500% radius and 200% falloff, and there are far less particles left behind, but still, after a while, i end up with streaks of static particles.