Cloth tyCache motion blur problem with vray

My big issue is;

1.I can't get motion blur from vraycamera with my cloth tearing animation while using tyCache. I am using v0.16043 and tried to disable shell and chamfer. 

Other minor problems;

2.If cache to RAM motion blur generally works. When it doesnt work i need to uncheck and check again motion blur checkbox at camera settings and it works again.

3.Even i cache all animation to RAM waiting times before starting rendering for each frame gets longer and longer. 

4. When i cache 1000 frames to RAM takes 15-30 mins. But even after all the animation is cached i wait 1 minute to change a frame at viewport. If i use tyCache it takes much longer to write files than i expect. I use tyCache after caching already in RAM. It writes first 500 frames (1.5 GB) in only 8 mins and last 500 frames (3.5 GB)  in 4,5 hours. 

tyFlow is amazing. Thanks for your work!
It's impossible to debug these issues if you don't post a scene file.

Here are some tips anyways:

1) Confirm that vert/face counts are really not changing from frame to frame. To do this toss an edit mesh modifier on your cache and type $.numverts and $.numfaces in the maxscript listener and various frames to confirm the topology is static over time.

2) There must be something wrong with your setup or some other issue you aren't noticing because making camera changes has zero impact on the data a tyFlow outputs to VRay.

3) You've probably got some render-only settings on an input object, causing the flow to reset at rendertime because your object(s) change.

4) Keep experimenting and watch the maxscript listener for tyFlow debugging output. tyFlow prints out relevant info regarding simulations. Please see the docs on the Debugging rollout for more info you can print to the listener, to further debug why things are taking so long.
Thank you for quick response and tips. I figured out that after updating tyFlow if i start my flow from scratch, motion blur bug is fixed. I thought my existing animation's bug would be fixed if i update tyFLow.
Hello. I made some debugging and noticed that, if i use collision with cloth simulation motion blur does not work with tyCache. I checked $.numverts and $.numfaces. Face count does not change but vertex count is changing frame by frame. With collisions disabled vertex count still changes but motion blur works with tyCache.
Collisions have nothing to do with mesh calculations, so something else is wrong.
I sent my file by PM. It would be great if you can check the file. Thanks.
Thank you for the scene file, I'm not sure why motion blur isn't rendering properly, but at least I can reproduce the issue and will hopefully be able to get it solved in the next build.
So I thought I could repro the issue but it turns out I was accidentally testing the wrong tyFlow version (was using tyFlow for VRay 3.6 in a max install with VRay Next). Once I used the proper tyFlow version, motion blur rendered fine both in the cache and the flow.

Can you confirm you've installed the correct tyFlow version with your VRay install?
It is weird. I am using correct version. And i tested the file i sent you with different computer, max and vray versions. Same results for me, i cant get motion blur with cache but it is okay with flow. I noticed that with cache VrayVelocity doesnt work too. Only when i delete colliders cache and motion blur works. Do you have any advice for further debugging?
In the tyCache settings, what does the little textbox say about VRay? Right under the instancing option. Does it say vray is compatible?

Forum Jump: