About [TIMING] start frame and end frame influence
#1
Hi everyone! trying out TYflow and had a quick question.

its regarding TIMING panel on many of the force operators.  

basically what i was trying to achieve

1. birth particles 0f - 100f

2. from 50f, get a force to kick in (using the TIMING panel start frame : 50f), affecting ALL particles (even the once created before 50f)

however, when i run the simulation, particles that are birthed before 50f are not affected by the force.

just to clarify, i have birth, force all in a same event.

i was assuming the TIMING panel to be like trimming, where i can control when the forces become "activated".  
so when the FORCE is activated on 50f, my assumption was that all the particles in scene (i have not set any filters or anything) will be affected by the FORCE, not just the particles created afterward?

of course i could leave the TIMING panel as is, and just animate the actual FORCE parameters, but just wanted to understand the mechanics better.

thanks in advance for any response!
  Reply
#2
What's the timing mode set to? Frame? Event Age? Perhaps if you screencap your flow and the settings within I can see better what's going on.

What you want to achieve is definitely (and easily) achievable, just gotta get the right settings Smile
  Reply
#3
thank you for a quick response ; )

i actually tried everything on it, but all seems to show same behavior (except the continuous, it seems to just kick in from 0f)

i have attached a screenshot of my EVENT, simple event, birth from 0-100, and i have the CLUSTER FORCE setup to start from 50-350f.

however, when i run the simulation, all the particle created pre 50f are not effected.  

thanks!


Attached Files Thumbnail(s)
       
  Reply
#4
Why don't you use "time test" operator, set to frame (for example 50), and then in new event you place cluster force. 
That way, in 50 frame, a force will affect every particle.
  Reply
#5
(09-14-2019, 08:21 AM)d4rk3lf Wrote: Why don't you use "time test" operator, set to frame (for example 50), and then in new event you place cluster force. 
That way, in 50 frame, a force will affect every particle.

yep, that was another method i was considering.  but i thought TIMING panel was interesting, as it enabled me to keep everything in a single event.

not sure if having things in a single EVENT is better or worse, but this was a function i didn't see in particle flow for example, so thought i test it out.

or alternatively, i could keyframe the FORCE INTENSITY, but i liked they way how i could setup the FORCE, but control when it is ACTIVATED via the TIMING section.
  Reply
#6
For me, it works 
(if I understand you correctly). 
Al in single event

Attaching you a file. 
Particles are generated from 0 to 100, and at 50. frame, cluster force starting to affect all the particles (timing set to frame from 50 to 1000).


Attached Files
.rar   particles-2016.rar (Size: 51.41 KB / Downloads: 4)
  Reply
#7
hey DarkElf, thank you for your file, i have downloaded it and tested, and it works just fine, and this was exactly what i was describing.

so i went back to my file, to narrow down what was causing my issue, also trying to simplify the scene so i can upload it as well for anybody interested.

while testing, turning things off, figured out it was the particle physics that was different.

so when i turn off the particle physics, everything works as intended, particles are all affected.  however, when i turn on the particle physics, the problem i described earlier happens.  not sure if this is a bug, or my setting is not right on the particle physics.

would really appreciate any help : )

i have uploaded 2 screenshot of my current settings, and also uploaded the max file (max 2018, vray)

thank you in advance for any help!


Attached Files Thumbnail(s)
       

.zip   delete-particleTest.zip (Size: 207.46 KB / Downloads: 5)
  Reply
#8
I've taken a quick look at your system. 
Your "cluster force" is too weak. When I increase attack/repel parameter to above 0,4, it starts to affect all the particles. 
Also, don't forget to change timing from "particle age" to "frame". 
(use "particle age", if you want to affect each particles when they are born + 50 frames.. so, if one particle is born at 10th frame, the force will start affecting him in 60th frame) 
(use "frame", if you want to affect ALL the particles at 50th frame). 

If the "cluster force" turns out to be stronger then you want, you might want to use "slow" operator bellow it, to slow them down. 

Now, keep in mind that I haven't used "cluster force" operator myself, so I don't really know how it affect particles exactly. 
Regular force operator is enough (so far), for me. 
All in all, my blind guess is that your particle physics operator is stronger then "cluster force", and that's what keeps some particle in place.
  Reply
#9
interesting... though my assumption on the CLUSTER FORCE was controlling intensity not affective radius?

its first time using CLUSTER FORCE as well, so i am tweaking numbers to get what looks good as well.
what i find is those numbers are quite "sensitive" and requires quite small number to get a slow smooth movement.

but i like you suggestion on combining it with SLOW to compensate for it.

any explanation from TY would be awesome to help me understand the mechanics ; )

anyway, thanks heaps for your help DE! much appreciated, if i figure anything new out, will post it here for others~
  Reply


Forum Jump: