tyflow-phoenix fd collision issue
#1
Hi

iv come across a problem with the interaction between TY and PHX

simple test destruction scene setup

i have a box that is voronoi'd and then a sphere collides with it.

now , PHOENX is emitting a simple column of smoke from a box (scene object , non-TYflow)

if i then simulate PHX with the just my TY collision spheres it works, but as soon as i simulate with my "destruction" and sphere it doesnt work.

also, if i export all my TYFLOW as scene objects it works as expected.

here are pics to illustrate, and also a simple scene setup

if u sim SMOKE with TYFLOW  EVENT 1 off, the Sphere effects SMOKE fine, if u switch it back on it doesn't

regards

Harv


Attached Files Thumbnail(s)
           
  Reply
#2
Can you post a screenshot of your flow, or upload the file?
  Reply
#3
(11-28-2019, 03:49 PM)tyFlow Wrote: Can you post a screenshot of your flow, or upload the file?

sorry Tyson , i thougth i had uploaded the file
my bad


Attached Files
.max   tyflow-phx-test 03.max (Size: 2.68 MB / Downloads: 4)
  Reply
#4
Works fine for me in Phoenix 4.0.

For prior versions of Phoenix, try disabling the particle interface in your tyFlow and see if that works...that might help to force Phoenix to detect the meshes of the particles. I think in versions prior to 4.0 the order in which Phoenix grabs meshes and particle interfaces was different...it might be treating your chunk particles as points, thereby preventing the meshes from affecting the sim directly.
  Reply
#5
(11-30-2019, 09:05 AM)tyFlow Wrote: Works fine for me in Phoenix 4.0.

For prior versions of Phoenix, try disabling the particle interface in your tyFlow and see if that works...that might help to force Phoenix to detect the meshes of the particles. I think in versions prior to 4.0 the order in which Phoenix grabs meshes and particle interfaces was different...it might be treating your chunk particles as points, thereby preventing the meshes from affecting the sim directly.

Ok Tyson
i think we're due to upgrade to PHX 4 soon, so i will test then.
I'll have a go at your suggestion too.

Thanks Tyson

Harv
  Reply
#6
Sorry Tyson

another querstion regarding this
so with "particle interface turned off" the PHX sim picks up my TYFLOW as collisions, but if i do a TYCACHE, then disable the "particle interface" in that it still has no effect on PHX sim.
Also, Iv tried exporting to scene objects, which works well, aprt from when the GEO scales to zero, this plays havok on my PHX smoke sims and causes "spikes" due to it scaling down.

Any suggestions, for ""workaround" for both the above?

cheers
Harv
  Reply
#7
Turn off GPU acceleration on the tyCache.
  Reply
#8
(12-06-2019, 04:12 PM)tyFlow Wrote: Turn off GPU acceleration on the tyCache.
nice one Tyson

awesome 

cheers
Harv
  Reply


Forum Jump: