Tyflow too slow to simulate
#1
Hello there, I am new to Tyflow in 3dsMax.
I am trying to simulate a train with its first carriage pushing some snow out of the track.  I am starting with 500.000 particles.

It's just impossible to scrub back and forward as it keeps loading the cache for each frame, therefore freezing my viewport. 
So how is the workflow ? Do I export particles as PRT from the outset and then start experimenting?

Many thanks.
  Reply
#2
Sounds like something is broken in your scene. 500k particles should scrub without issue. I don't know what you mean by "loading the cache for each frame". The live cache stays in memory and nothing needs to be loaded. Maybe share your scene so we can see what's up.
  Reply
#3
Thanks for the reply.

Yes, you were right. After creating another scene and replicating the same simulation with more simple objects, found out the "collision operator" was the culprit in the previous scene. Even deactivated/dimmed it was still breaking the scene somehow. So I decided to ditch that scene and start all over.

It's now possible to scrub the timeline more easily.

When I said the cache is "loaded", I actually meant "updated". So what can I do to calculate all event's simulation and leave it in the memory for easy access ?  In Phoenix we can press "start" button to calculate and we can manipulate the scene in the meantime. Then, after calculating, it's very easy to scrub the timeline. With Tyflow I am not sure what is going on... the more events and operators I insert, the more calculation I need, the less timeline scrubbing I can do, and more time I spend just staring at the monitor...

I thought maybe if I exported the Tycache or PRT and then importing it back somehow I could make the process easy, but my scene crashes midway while exporting 400 frames with 500.000  particles.

So what I am doing wrong ?

I have attached a screengrab below. Sometimes I disable the flow, move the time slider to the frame I want to see and enable the flow...


Attached Files Thumbnail(s)
   
  Reply
#4
Did you disable the caching option in the tyflow object? If you disable this it will have to update all the calculations per frame and is very slow. If this is enabled it will save all those calculations in the ram and will enable real time scrubbing and playback of your scene. It can fill up a lot of ram if you have a ton of particles though, i can easily fill 64gb ram with a few million.

If you have a sequence that you want to save with the PRT/tyflow cache operator, but it has more particles than your ram can handle, you can disable the cache in the main tyflow object settings. It will have to recalculate every frame (before it saves the cache on HDD) however it will allow you to scale things up higher than you normally could. This is very useful when you are partitioning caches for a large simulation such as a krakatoa render. (tens or hundreds of millions of particles)


Attached Files Thumbnail(s)
   
  Reply
#5
Thanks for the reply Shadowkiller,

I normally leave the caching option in the tyflow object ON. The scrubbing is okay in the beginning of the time range. But if I scrub around the end, say around 300-400, I have to wait a lot for the simulation update. 

That's why I thought maybe exporting PRT cache would be the best. I did Friday night before left my studio to export PRT 1-100 frames only, and again, my 3dsMax crashed at frame 81... This is the third time my 3dsMax crashes while exporting PRT files.

Does it have to do with my RAM ? 

So do you mean that if my supposedly RAM limitation is preventing me from exporting the PRT cache, I will have to disable the "Enable Caching" in TyFlow and only then export /Generate the PRT files ? But don't I need the "Enable Caching" ON in TyFlow to export the same cache ? 

I am not sure about what "partitioning caches" you mean, I think I have to research more about this topic. So Tyflow alone is good for small simulations and if I need large simulations like the one I am doing (a train pushing a bunch of snow out of the track), we will have to buy Krakatoa render ?

Thanks for the reply guys.
  Reply
#6
We can't tell what the problem is unless you provide a scene file, crash minidump, etc.

tyFlow can handle huge numbers of particles but you have to be mindful of your RAM when working with large numbers of them.
  Reply


Forum Jump: