Low Gravity and VrayDisplacement
I'm new to tyFlow but already loving how snappy and user friendly it is.

I'm encountering two issues right now. First I have an issue with gravity. I'm trying to make a basic falling simulation of my own 3D scanned pastry model. My scene units are set to millimeters and all objects are at their real world size without any additional scalling applied to them. I am using the Shape module to instance the original in the scene as a reference node. The simulation works fine but the gravity seems to be way too low, making it look like they are falling in slow motion. The default gravity setting was at -1mm after clicking the "real world" button it changed to -1.188mm. My playback is set to real-time and I have now fps lag in the viewport. The animation itself is set to 25fps. I first thought this issue could be because of a wrong mass setting in the PhysX Shape module but changing it didn't really help me. Making them havier just looked like heavier objects falling underwater. After changing the gravity manually to -3mm it looks more realistic but adjusting this purely by feeling seems weird to me. Am I missing something basic?

Here is a screen capture of the simulation. Don't mind the lagginess, I assume it's because I captured on my bigger resolution screen. It looks much smoother in my viewport but the playback speed is the same. You can clearly see what I mean with low gravity and slow motion.


My second issue is related to the VrayDisplacementMod that is applied to the original objects that are being instanced. It doesn't work during rendering on the simulated instances. Is this something that's just not supported (yet)? My solution right now would be to subdivide the model, add a normal displace modifier and then export that highpoly model as a vray proxy... then load it in tyFlow instead. I just wanted to know for sure beforehand that my current setup won't work.
EDIT: I just found Tyson's explanation on the VrayDisplacement issue. Since I would need to run the objects as trimesh instead of instances I guess it won't work for me. I'll probably try the proxy solution.

Thanks in advance for any advice.
Quote:My scene units are set to millimeters and all objects are at their real world size

Could be a bug on my part...I think tyFlow may assume that 1 unit = 1 inch, regardless of unit display settings...I'll double check that.

Forum Jump: