tySplines with retimed cache
#1
Hi all, I think I'm running into a bug here, but maybe I'm missing a step.

This issue occurs when retiming a tyCache file that had the "include spline paths geo" setting turned on.

The scene I'm working with has some spheres that are floating in space, but then come together to form an object. I made the animation going backwards (where the spheres begin on the object, then begin to float away), cached it out, and retimed the cache to flip it. I also slowed the cache down a bit, and this is where the issue comes in.

Once the spheres get close enough, I have a tySpline object set up to connect them to each other. But, when I slow the cache down, the sphere's positions update as you would expect, but the spline geo does not. It only seems to update once it hits a new frame in the cache. So if the cache is at frame 1.7, the sphere geo is at 1.7, but the splines are at 2.

Changing the subframe sampling seems to have no effect. Even at 1/32, the spline geo only updates when it reaches a new frame.

I attached my scene file. Just open it up, export a cache, and use the tyCache I already have in there (it's got the retime already animated).


.max   TySplines_Test_01.max (Size: 7.54 MB / Downloads: 24)
  Reply
#2
Hi Pheyn,

This behavior is expected. When tySplines are exported by a tyCache, the tyCache only includes the raw geometry...changing topology and all...so when you attempt to retime it directly like that, you'll run into interpolation issues.

The solution is to use the retiming settings in the tySpline object to retime your splines before export. Once you are happy with your settings, then export to tyCache and things will be smooth.
  Reply
#3
Hi all,

I'm trying to play a tyCache backwards like the above post - but can't seem to find out how to do it!

I made a simple particle animation of particles going from A to B, frame 0 to 100 - now I want to play it backwards.

Tried using the Retimer, with Speed% set to minus 100% but it still plays forward.

How should I do this?
Thanks
  Reply


Forum Jump: