typreview_error retrieving viewport DIB
the ty-preview was working fine when i first installed the tyflow update.. however now  (i have changed nothing in my setup, software or hardware wise) it fails with the error message listed in the thread title. 

ive tried with two different max scenes. 

i thought it might be due to having two copies of max open, but  it does the same with 1 open.
Hmm, that particular error can only happen if max's built in viewport DIB retrieval (essentially viewport screencap) function fails. It's not even a tyFlow function so it failing on your machine is very strange.

Can you open your maxscript listener and enter the following:

display (gw.getviewportdib())

And tell me if a window showing a viewport screencap pop ups?

If the tyPreview issue happens consistently across all scenes, can you maybe send me a max file from your machine where the issue occurs? Just so I can double check the saved tyPreview settings in your scene to make sure nothing else weird is going on.
well i tried the maxscript thing, and a viewport screengrab did indeed work. i then tried typreview and got the error again.

im just finishing some rendering, but i will restart my machine and try with a diff scene later today.

Forum Jump: