Max crasches as soon as I press Tyflow button
#1
As soon as I press any TyFlow button 3dsmax crasches (2018 & 2019), also if I try to open a sample scene it crashes.
I've a quite old rig ( intel q6600) so I'm wondering if Tyflow needs some instruction that my cpu doesn't handle, maybe SSE4.2 or similar?

Thanks
  Reply
#2
Hmm...that's no good....although I don't think I'm using SSE4.2 anywhere.

What version of Windows are you on?
  Reply
#3
I'm on windows 10 lastest update.
so, if it's not a cpu issue, maybe a pluggin conflict?

I'll try to download the new 2020 demo, maybe a clean install will work.

I'll let you know what appends...

Thanks
  Reply
#4
Well, the fact that it crashes as soon as you try to create a tyFlow is very odd...points to maybe a deeper issue. Let me know if works in the fresh 2020 install.
  Reply
#5
ok, I've tested with 2020...same thing, as soon I click on TyFlow Max crashes.
I was thinking, the only things the 3 3dsmax installation shares is I've not installed Arnold render….could it be this?
  Reply
#6
No it shouldn't be that...I don't have Arnold here and it works fine...

What kind of UAC permissions are set on your machine?
  Reply
#7
Before you asked me UAC was on default level, now I've lowered to the minimum, but nothing changes.
 Could it be useful to send you some dump file?
Just in case, wich one? the minidunp? the dump data? all of them?
  Reply
#8
If you're able to send the minidump I could try to take a look, although I'm not familiar with the 3dsmax dump format.

I might send you a build later that has some extra logging in place so we can see where in the initialization function things are going awry....just trying to sort out some other bugs first Smile
  Reply
#9
Here is my minidump, hope this helps.


Attached Files
.zip   3dsmax_minidump.zip (Size: 740.94 KB / Downloads: 74)
  Reply
#10
Hey cylon, just curious....does the most recent build (v0.16007) work for you? If not, I'll send you the debug build. I tried examining the minidump but forgot that I had accidentally overwritten the relevant .pdb files earlier, so wasn't able to process it.

Hopefully we can get this issue sorted out.
  Reply
#11
Hi, I just tried the new build, unfortunately nothing has changed.
Somehow I managed to read the data of the minidump, I enclose a text file, it is the first time I do, so I do not know if what I got is useful.
Ps.
I know you're very busy with the new beta, I really appreciate your commitment to solving my problem, taking into account that it is very old hardware; So thank you!


Attached Files
.txt   tyflow_07_beta_debug.txt (Size: 15.2 KB / Downloads: 115)
  Reply
#12
Ok, I've just tested the .08
same thing.
I'm starting to think I'll never have fun with this toy!

Edit:
I've tried to create an tyFlow object via maxscript ( tydlow pos: [0,0,0] )
Strangely it didn't crashed, anyway no object was created, BUT, this time I was able to read all the errors reported in the listener, so, here there are:


tyFlow warning: failed to initialize AuraLoader with threadManager. Multi-threaded PhoenixFD loading is disabled.
-- Known system exception
-- ########################################################################
-- Address: 0xc7f97abc; nCode: 0x00000000C000001D
-- Desc: EXCEPTION_ILLEGAL_INSTRUCTION The thread tried to execute an invalid instruction.
-- ########################################################################
-- MAXScript callstack:
-- thread data: threadID:31452
-- ------------------------------------------------------
-- [stack level: 0]
-- In top-level
-- ########################################################################
-- C++ callstack:
-- (tyFlow_2020): (filename not available): (function-name not available)
-- (tyFlow_2020): (filename not available): NodeAndAnims::SetNode
-- (tyFlow_2020): (filename not available): (function-name not available)
-- (3dsmax): (filename not available): MaxSDK::PointCloud::UBytePoint4::operator=
-- (MAXScrpt): (filename not available): MAXClass::lookup_class
-- (MAXScrpt): (filename not available): MAXClass::apply
-- (MAXScrpt): (filename not available): CodeTree::eval
-- (MAXScrpt): (filename not available): Listener::set_style
-- (USER32): (filename not available): PeekMessageW
-- (USER32): (filename not available): IsWindowRedirectedForPrint
-- (USER32): (filename not available): IsWindowRedirectedForPrint
-- (USER32): (filename not available): DispatchMessageW
-- (USER32): (filename not available): CallWindowProcW
-- (UIControls): (filename not available): (function-name not available)
-- (UIControls): (filename not available): (function-name not available)
-- (USER32): (filename not available): DispatchMessageW
-- (USER32): (filename not available): DispatchMessageW
-- (USER32): (filename not available): IsDialogMessageW
-- (3dsmax): (filename not available): NodeAndAnims::SetNode
-- ########################################################################
  Reply
#13
Those are some very odd errors indeed...

Can you confirm, are you using an English-language version of windows?
  Reply
#14
No, it's the Italian version. Is it a problem?
  Reply
#15
A few people have been having some issues with non-English versions of 3dsmax....

Any chance you could try temporarily switching to English Windows and seeing if you can load a tyFlow? If you don't get the crash, that will help me track down what the issue is Smile
  Reply
#16
Ok, I can try, I just have to find an old hdd ... And download an English version of windows
  Reply
#17
I think you can just change the language settings Smile You shouldn't need a whole new install.
  Reply
#18
Oh... yes, sometimes the simplest solution is the best! Wink
  Reply
#19
Ok, I've tested english (uk) & english (usa), same error! Sad


any other idea?
  Reply
#20
Hmm, and just to be sure...when you delete the tyFlow .DLO from your max plugins folder, the error goes away?

I can send you a debug build that adds some extra logging, to hopefully figure out what's going on. Just PM me your email address Smile
  Reply
#21
Just to clarify, I get the error only if I press the tyflow button or if I try to create an tyflow "object" using the ma script command, if I delete the dlo I don't have any tyflow button to press or any command to run in the ma script, so I can't get the error; even if I don't delete the dlo file, I can work without any problem in 3dsmax as long as I don't touch the "create tyflow" button or I try to open one of the sample scene.

Ps.
Just tryed to open a sample scene without the dlo and I can open it, obviously I get an error message saying that I don't have the dlo!
  Reply
#22
As I told you in the PM, I have some doubts on the files I download.

As far as I unzip the files via the windows util it seems ok, but if I unzip it using 7zip I get an error.

I don't know, maybe is this causing my problems!


Attached Files Thumbnail(s)
   
  Reply
#23
Can you try extracting with winrar? That's what I used to zip them.
  Reply
#24
Extracting the file with wrar gives no error, but max keeps crashing.

Tell the truth, you are packing a special version of tyflow that crashes max specifically for me....  Big Grin
  Reply
#25
I have a similar problem.
I tried an older build and did pretty much the same. With latest build when I use 2019 or2020 it crashes max upon start up. I don't even get to the point of clicking on the tyflow button. It is very weird as my wife has the same razer laptop, same plugins, same drivers and it works great for her. The only difference is my machine is a university machine which has a lot more security restriction stuff installed... So could be related to that?
  Reply


Forum Jump: