Position Object Separation setting
Hi Tyson,
Hope you're doing okay. I'm very new to Tyflow so I might be doing something the wrong way or misunderstanding how this setting should work. I apologize if that's the case.

Now, the issue. I was trying to replicate this hairbrush teeth distribution. 


For that I used a birth, then a shape to assign a custom geometry from my scene and then a position object and picked a surface to scatter the teeth on. I was looking for an even distribution so i thought that turning on "separation" would be the way to go but it didn't worked as I expected, even after tweaking the "distance" and "tries" settings, and also the number of born particles. As you can see in the following screenshots there are some particles that are very close to one another, as if they were ignoring the "distance" value, resulting in a very uneven distribution.

Below, same simulation with different "display" settings 


Below, EDITOR WINDOW of said simulation

I know that, being such a new user, I might have misunderstood the documentation and this is not how it's supposed to work (or even this setting was never meant to be used this way) so I apologize if that's the case.

In case anyone wants to do something similar to this and is running into the same issue, a user of facebook suggested raising the number of particles and using a Fuse operator to control the teeth density. This worked perfectly.


Also, thanks for this space to share and, or course, this amazing piece of a plugin  Heart Exclamation

Hi Manuel,

It's strange that the separation option is not giving you even distribution. I will look into it Smile
Thank you!
Hi. I tried to reproduce the issue today and yesterday and I haven't been able to, also using the same scene. Even if I haven't been able to use the exact same geometry because I deleted it , I used a very very similar one.
I think that I might have misclicked somewhere without even realizing. Next time I'll try to replicate it from scratch before posting.
Sorry for wasting your time and thanks for your commitment to this project.

Forum Jump: