TyFlow actors disappearing when using RS instances
#1
Hi,

I've just been trying out the experimental support for Redshift instances, and noticed that actors disappeared on a couple of frames using the Crowd/Arrow scene (bumped up the number of actors, and had them appear on frame 0)

All the mesh ops seem to be set to render instances, but wasn't sure if animated meshes were fully supported yet?


Cheers

Steve
  Reply
#2
Umm, it won't allow me to attach files - they seem to upload but nothing shows up?
  Reply
#3
Click the attach button after browsing to your file.
  Reply
#4
Cheers!


Attached Files
.mp4   crowd.mp4 (Size: 7 MB / Downloads: 20)
.max   tyFlow_arrows_001.max (Size: 940 KB / Downloads: 11)
  Reply
#5
(04-06-2020, 02:49 PM)SteveDeeGreen Wrote: Cheers!
Hi, one more thing (almost on the subject:-)
First; Tyflow and Redshift are a beast of a combination i must say, unbelievable speed and fun!
But when i render a tyactor with enable particle interface the characters bones gets rendered.
Turning off enable particle interface hides the bones (as it should be i assume.)
See attached render. I posted in redshift forum as well.




I use tyFlow_016084 (latest to date) and redshift_v3.0.18

Best /nico


Attached Files Thumbnail(s)
       
  Reply
#6
Don't disable the interface, disable the Mesh operator. That's what's triggering them to render.
  Reply
#7
(04-29-2020, 05:33 PM)tyFlow Wrote: Don't disable the interface, disable the Mesh operator. That's what's triggering them to render.

Ok! That did the trick!! big thanks!!
  Reply
#8
(04-29-2020, 07:54 PM)nicoknudsen Wrote:
(04-29-2020, 05:33 PM)tyFlow Wrote: Don't disable the interface, disable the Mesh operator. That's what's triggering them to render.

Ok! That did the trick!! big thanks!!

One more thing on this:
When i render out tyflow actors using "Enable Particle Interface" they render without smoothing.
Despite adding TySmooth on top of the icon, or adding a smooth operator in the flow. 
Turning off "Enable Particle Interface" then Tysmooth works and the actors are smooth.
-But then ill have do build a big tree of materials since Tyactor doesnt seem to render with the materials from the Tyactor anymore, despite checking "Instance material". 
With "Enable Particle Interface" on the materials get rendered correctly but without smoothing.
Make sense? anyone with a sollution?
Best /nico
  Reply
#9
Managed to "fix" the smoothing problem with actors!
I added a Tysmooth below the skinning of the actor, and then it worked!!
  Reply


Forum Jump: