How to stop jittering after collision?
for sure a baisc question, but which settings can suppress jittering?

I did a simple test scene and played with all SIM settings, also "Collision compensation",
but it makes no difference.
Short screen recording here:

Hello, i have always the same problem in my simulation.....particle jitering
if someone can post a tiny exemple of wich operator can solve the problem it could be very helpful.

and good luck alexx
Hi layen, I know of course, that PhysX Switch can stop it,

But my question is, if that kind of "workaround" is really the professional workflow.

I would expect a possible basic setting at least for simple collisions.
Would be great to get an answer from experienced people.
(05-15-2020, 04:23 PM)Alexx31 Wrote: I did a simple test scene and played with all SIM settings, also "Collision compensation",

This is under the Particle (Physics) bind solver, and has nothing to do with the PhysX you (apparently) using in the sims. 

Guys, there are 2 (dynamic) simulation solvers in TyFlow: 
1) PhysX
2) Particle Physics (granular solver) 
So, both of them have a separate options, and are completely independent of one another (neither work with one another). 
They have different use. You'l use PhysX when you want real (convex) shape collisionns (like fragment meshes), and stuff like that, and Particle Physics is much faster, but only works with "dots" type of collisions (imagine like a point collisions), and it's not good for fragment with volume, but is good for, example, sand simulations (of course, you can do a sand simulation with PhysX, but much slower). 
Almost every operator works with both solvers, and both solvers has their own unique operators (for binds, for switch). 

There is also cloth solver, but that's another story. 

Hope it's clearer now. 

Ok, now to answer about jittering. 
First thing you will try is increasing time step parameter (select Tyflow Icon, go to modify, it's under Main Settings) from 1 frame to 1/2, 1/4 or more (this will help for both solvers). 
This should help you in 90% of the cases (at least, from my experience) 

If that doesn't help, and if you're using PhysX, then go to PhysX rollout (again, on icon), and try increasing substeps, and these other 2 settings (position and velocity). 

Now, I had simulations where even all above didn't helped, so I just used simple thing 
Property Test operator (Test type: By velocity magnitute) , then I say... if particle is slower then this value, then just send it to next event (and next event have just Stop operator). 
That way, every particle can get crazy all they want Smile but  if they start moving very slow, they will be ordered (sent to next event) to stop moving Smile
awesome! thanks a lot for this explanation!
thanks d4rk3lf,

i will try your tricks with the operator property test.
i had already tried with magnitude deceleration with no good sucess with binded broken element...but i think i made lots of forgotten error by tweeking all parmeters....
d4rk3lf's answer is great, I'll provide the "official" answer as well.

There are different types of common jittering that can occur:

* general PhysX rigidbody jittering: fix by lowering max velocity values in the PhysX Shape operator, increasing PhysX substeps, decreasing tyFlow time step
* PhysX Bind jittering: increase pos iterations setting in global PhysX parameters, as well as increasing PhysX substeps, etc.
* Particle Physics jittering: decrease Particle Physics collision stiffness, and increase Particle Bind Solver steps
* Partilce Bind jittering: decrease particle bind stiffness and increase Particle Bind Solver steps

All jittering in tyFlow is ultimately setup-dependent but the good news is that all of it is pretty easily fixable. It's usually just a matter of wrangling the above settings. Typically doing hacks like converting RBs to kinematic or adding artificial drag, etc, are not necessary.
Thanks Tyson and D4Rk for this summary which help not to get lost in the mistakes that accumulate mismatch

Forum Jump: