Tyflow and Biped Subanims cause recalculate every frame
I have a rig that is using biped and tyflow.  Tyflow 16106.  Max 2021.

I needed to animate the neck getting longer so I added a subanim scale control to the neck links.

When I activate the subanims Tyflow acts as if the caching is turned off.  It recaculates all the flows on every frame.

If I turn off the subanims Tyflow works excactly as it is supposed to.

Likely improper reset notifications sent out of the biped. Unfortunately CS is a stagnant tool in the sense that plenty of bugs still exist in it, and it has not been actively developed for years. Since an improper reset notification cannot be distinguished from a proper one, tyFlow doesn't know that it shouldn't update and I have no way of filtering such messages manually (usually they exist in the form of a generic REFMSG_CHANGE message sent through the max pipeline...so tyFlow can't decipher when one is sent improperly, compared to a proper change triggered by user input).

You can set the simulation reset mode to manual from the editor right click menu to at least disable auto re-caching when a change notification is received.
Ok, I will try that and see what comes of it.

I will also report it to Autodesk.  Leave it on the long list of fixes.


Forum Jump: