Have particle orientation align to spline
#1
Hi Guys, 

Been playing with Tyflow for a couple of days now and its really cool but I cant seem to get my particles to align with my spline (its a helix) they all face one direction where i would want them to follow the spline and the direction of the spline.

Might be me being a noob but cant think of a way to do it

Any help would be great
  Reply
#2
Rotation operator -> Align to Surface -> add your spline to the objects list.
  Reply
#3
(07-04-2019, 04:34 PM)tyFlow Wrote: Rotation operator -> Align to Surface -> add your spline to the objects list.

Thanks for getting back to me, i tried doing that but it still changes orientation around the helix, I will shortly post an image of what i mean
  Reply
#4
(07-04-2019, 04:34 PM)tyFlow Wrote: Rotation operator -> Align to Surface -> add your spline to the objects list.

As you can see from the attached image, they don't orient themselves to the spline as such.
There is probably something that I'm being a total noob at but I can't seem to get it to work


Attached Files Thumbnail(s)
   
  Reply
#5
Did you add your spline to the object list in the rotation operator? You seemed to have missed that step. I am able to get the desired effect with teapot and helix.
  Reply
#6
(07-05-2019, 09:08 PM)Syu_z Wrote: Did you add your spline to the object list in the rotation operator? You seemed to have missed that step. I am able to get the desired effect with teapot and hel
Hmm thats odd, I definitely did add it to the list and tried it multiple times with different settings etc 
Ill try starting from scratch with a teapot and see if it works, if it does work with the teapot then could it be the source mesh for the particle ?
  Reply
#7
Did teapot work?
  Reply
#8
(07-11-2019, 12:17 AM)Syu_z Wrote: Did teapot work?

No not initially but i've managed to kind of fudge it to get it to look right. 
Will detail what I did to fudge when im back at work
  Reply
#9
Hi guys,


first: tyFlow is really amazing! Many thanks to Tyson!!!


Here is my problem though:
I also try to align particles along a spline. 

Unfortunately I still have issues with the orientation.
If I use "Sibling Align" the particles simply flip at 180 degrees.

If I use "Surface Align" some of the particles start at some point to turn.

Running out of ideas...

thx
rolf


Attached Files Thumbnail(s)
   
  Reply


Forum Jump: