Simulation stops for some reasons on random frames
Hi Guys,

I am having the problem, that my simulation also (corresponding to this thread: stops working from time. ~ 25.000 are beeing calculated average and it almost stops the first time somewhat at frame between 400 and 500. After restarting, it stops again at around frame 700... and so on.  Autosave OFF of course here... =)

thanks for any hints in advance
Can you describe the issue a bit more? What do you mean by stops? Max crashes?
no, not crashing. It just stops calculating. In my case mostly the first time around frame 470-490. I can go on, but just a matter of time, it will stop again.
I can export parts of the scene (check then, if it still does it) and send it to here. In the Moment it is impossible to leave this overnight, and having it done for breakfast... =)
I am having here the scene, which might describe it at its best. With 15 Particles per frame, it stops roughly and randomly at around 1000 and 1100. 
With 50 PP/Frame it happens at 400/500 around. So quantity of calculation/simulation is quiet somewhat in balance

(Using an AMD 16 Core with 64 Gigs of Memory and a Nvidia 1070 GTX. Just mentioned in passing.) Max 2021

all in all - thanks in advance

Attached Files
.max   randomsimstop@around1050-1110.max (Size: 3.49 MB / Downloads: 12)
Hi Guys,

I dont´t know... Huh

I tried some things to clear out what happens here since it still appears constantly: I used a brand new Windows /Max installation on the machine I encountered the first time. I tried another machine (this time an Intel machine) with a new Windows Max installation. It´s still happening. I tried it with Max 2021 and 2022. I build the easiest setup - just a cylinder and let it pour with whatever you want, simply just as long as it interrupts. It shares just one thing: Ram Modules. I took it from one Machine to the other, since I am only having only one set of DDR4. But for Sim. there is still enough Mem. usage left. Those are the only Intersections of the Setups.

this scene here is about to stop at frame 120 and one time at (frame 122-second attempt) and just press Play another time it goes to around frame 156 and stops again. 300000 Particles. So it is always a little different.

Can it be an issue with the same Memory sticks, which are the only component, which are present in both Machines?

Attached Files
.max   Silo_simple_testscene.max (Size: 6.87 MB / Downloads: 8)
I was able to sim to frame 150 without got pretty slow, but it never stopped. Not sure what the problem with your machine could be...I can't imagine it has to do with an actual hardware RAM issue....

For an issue where Max freezes, but doesn't crash, the only way to debug such an issue if I'm not able to reproduce it here is to have you install visual studio, attach to the process and then break execution and see where it stops. I could describe all the steps to you if you're interested in going down that route...
thanks so much for the Test! Well, I got also a friend of mine to test this. He says also, that it doesn't stop at all and was able to go until it was through.

In fact, I changed almost everything like Hardware and System /new Installation Windows/Max, etc. It´s hard not to believe that it is the Memory as the onliest component sharing the two Computers. But you will have also your reasons or experiences, saying that it would not be the Memory - or hard to believe ( so memory is doing a rendering for Days long  - no Prob at all)

Well, Visual Studio... =) Never Used it. A bit of help would be pleasant then. But: Fact is, that Max never freezes. It simulates and then it simply stops. I press only "play" again and it does for a certain amount fine until it stops again. This is the Case when just hitting Play and the TyFlow internal Cashprozess goes along. Memory Usage is not significant. Route of that Road... (as long it won't be as long as the Silkroad or complex like Nil´s Delta...)

SO: The good thing here is, that I found out, that using an Export Particle node is keeping me from total drowning!
There is no stop at all anymore. Wich, I am very happy with (i am here in a Production situation...:/ )

PS: You said "pretty slow". Is there anything to keep in mind about getting a bit faster? I´m not expecting miracles, but maybe there are tricks. My AMD 16/32 Threads is utilized between 20-15% And My Geforce 1070 isn´t faster- Utilising around 2-3% ... don't know if it´s right, but it seems, that there are no steady 90-100% Utilisation on a GPU at all. Regarding faster Simulationprozess, I open another thread, because I have a Question about using Deadline, which seems a nice helper here - when it´s not too complicated. In the end, there are quite many Particles colliding, or? I did a comparable Test with Pflow and it seems, that it is even somewhat slower.

#8 say max doesn't freeze either? So it's literally just animation playback that stops?

That's probably just max's default automatic backup process (that's triggered every few minutes) stopping playback (when an auto-backup is triggered, playback will stop). If you want to cache a long sequence, instead of hitting play...just enter your desired end-frame in the frame type-in box at the bottom of the screen. Or click the timeline at your desired end-frame.
Unfortunately - autosave is set off.... Otherwise, it might be a promising hint! But I´ll check it on the other machine with brand new Installation and there this may be still ON.
So, one Machine, there maybe is Ram really the issue and on the other is the Autosave set ON and might stop for this reason ... well confusing. I´ll check this later.
It could be something else ending playback as well...either way, instead of hitting play (which will actually simulate slower because it has to both simulate and update the viewport), just click the timeslider to the desired end frame and let it run.
(04-29-2021, 06:10 PM)tyFlow Wrote: It could be something else ending playback as well...either way, instead of hitting play (which will actually simulate slower because it has to both simulate and update the viewport), just click the timeslider to the desired end frame and let it run.

Thank you, that helped a lot.
Really almost twice as fast as with viewport update. - and works like a charm.

Forum Jump: