tyCache particles do not render on render farm
I have a simple tyFlow system with generating particles as spheres around surface to use them in VRayDistanceTexture map. I try to simulate ship wakes from the moving ship. Everything works fine at this point. Then I decided to cache particles to prevent calculate particles again before each frame on render farm (Deadline). I use network path for tyCache. When I render locally using tyCache particles then everything works fine as with not pre-cached particles. But when I send this file to render on render farm tyCache particles do not work. Even if the same file renders on my working computer but via Deadline tyCache particles do not work. I have no idea what is wrong.
Have you confirmed that the network machines can all see the exact path to the tyCache?
(05-28-2021, 02:40 PM)tyFlow Wrote: Have you confirmed that the network machines can all see the exact path to the tyCache?

Yes, I confirm. The path is on mapped network drive. There are also all textures located on this drive. If this drive is not available to all machines then I will not be able to render at all.
Have you tried rendering in a local UI max on those machines?
As I said in my first email, I rendered with UI on my working computer and it works fine. Then I launched Deadline render node on this machine, so it started to work as one of the other render nodes and tyCache doesn't work. Same file but rendering via Deadline doesn't work.
I see, it wasn't clear to me that you were also using your workstation with Deadline, I thought it was only separate farm machines.

Can you load the max file saved for the deadline job (the one submitted with the job) locally and see if it renders in UI max?

Do you have any strange non-english characters in the path or something?

For tyCache to not render with deadline is very strange. Many users, including myself, rely heavily on deadline rendering of tyCache and it goes without issue.

I'm wondering if perhaps your VRayDistanceTex setup is causing the problem. Can you try rendering an extremely simple tyCache in an empty scene with no maps, no nothing...just maybe like a single box particle with no materials, no lights, nothing...and see if it renders on your network using Deadline?

It's possible it works locally and not on the farm because VRayDistanceTex might be relying on the cached viewport mesh for its data...and when you hit render on the network, that viewport cache is no longer generated. Try switching the tyCache render settings to Mesh and disabling the VRay interface in the tyCache settings as well.
I will try to load submitted file and try to disable VRay interface in tyCache. I already have tyCache render settings switched to Mesh, otherwise it doesn't work in VRayDistanceTex map. I have pretty simple setup for tyFlow but I will try create a new scene from scratch to confirm the issue. I will send that scene for your review later. I don't use any not-English characters in the network path.
Update. I have rendered locally file with tyCache I sent to render farm and it rendered fine. I don't have time to create new test file at the moment but I will make in a few days when I have time. In a mean time I render without tyCache.
This is my path to tyCache files:

p: is a network drive from shared folder on my work computer.
Seems fine...

If you send the file to support@tyflow.com I'll try rendering on a farm myself using Deadline and see if I can repro the error. A stripped down scene + the cache (just a portion of it if it's really big) would be best.
Here is the problem stripped scene (3ds Max 2021, V-Ray 5.02).
I was able to render first part of animation (frames 300-1200 with tyFlow Birth adjusted settings) without tyCache and it rendered fine. After that I tried to render second part of animation, frames 5000-5500 and I am having a problem even with tyFlow only, without tyCache. Everything renders fine locally, but when I send the file to Deadline render farm particles do not render. I am really confused. The provided scene doesn't use any external files.
Here is good rendered frame 5000:

Here is bad rendered frame 5000, rendered on Deadline farm but the same computer as a render node:
Well the tyFlow object in the scene you linked is set to non-renderable in its object properties, so that's why it's not rendering.

There's no tyCache object in that scene, so I can't check if it's also set to non-renderable...can you check that your tyCache is set to renderable in your original scene file?
Yes, tyCache object is also non-renderable. The problem is that I need to render tyFlow as a mesh particles to make affect in VRayDistanceTex map but particles should be invisible. How can I hide them if 'Renderable' parameter turns them off? If I make tyFlow or tyCache renderable and uncheck 'visible to camera' in properties they are still visible during render. 'Renderable' parameter shouldn't turn them off. Otherwise there are two switches to turn them off - by this parameter and in tyFlow main settings, what causing confusion and user error. And why does it work fine when I render locally if 'Renderable' parameter should turn off tyFlow during render? And another question is why everything works fine when I render frame range 600-1200 and doesn't work when I render 5000-5500? There is a lot of inconsistency what makes work with tyFlow very difficult. I really want to integrate tyFlow into my work process, but every time I try to use it even with the simple tasks I fail, and have to contact for help. Fortunately, your response is quick.
Well depending on your setup, tyFlow/tyCache have rendertime-only mesh generation processes that will get skipped if they are set to non-renderable, that may be getting cached internally during local renders due to viewport mesh generation requirements.

Going back to your tyCache-only setup, can you try to just render the raw tyCache (no vray distance tex, no non-renderable settings) through Deadline, and see if it appears in all frames?
I have tried to render tyCache itself with visible mesh particles on Deadline render farm. They work as supposed to work. I see them on rendered frames. Now, I need to make particles invisible but still make them to affect in VrayDistanceTex map. And I fail here. I try to hide tyCache, make it invisible to camera. When I render locally, I see effect from invisible particles in VrayDistanceTex, but when I render same frames over render farm there is no effect from particles. I give up.

Forum Jump: