Tyflow actor issue
Hey, I'm trying to convert a CAT rig into Tyflow so that I can simulate the character turning into fragments on death.

I've encountered 2 issues:
1- despite only selecting the character mesh, the actor operator also creates the CAT skeleton. Bright yellow is mesh, dark yellow is unwanted rig: https://i.imgur.com/bxv1C6M.png
The brown rig disappears from viewport but still renders if I disable the Display operator.
(the rig is originally set to display as boxes, and rendering disabled in object properties)
2- I've found no way to relocate the Tyflow character onto the original location in the world. I've tried moving it with the Position icon, but it's not perfect

Following this tutorial until 9:00 https://www.youtube.com/watch?v=Qi2yxgfcZRg
If this is an issue with CAT rigs, maybe I should try converting the rig and animation to a different rig system?
CAT rigs are fine. You're seeing the bones because they have to be imported in order to compute skinning. Just disable your Mesh operator if you don't want to render them.

You can locate the character by moving the actor root particle.
Thank you. It seems that Arnold renders it even if toggled off. The mesh operator has no influence on what is rendered with this render engine, for some reason.  Confused

Would I have to bake the skin animation to vertex animation? I don't know how. I've tried a vertex animation bake script from scriptspot, but it doesn't seem to work with skinned models

(Arnold renderer is standard with Max for 2018+ I believe)
Oh right, I think Arnold had the bug where it doesn’t respect mesh operators while instancing….I forgot about that. The tyFlow to Arnold connection was implemented by Autodesk so that’s something they’d have to fix.

Try this: in the interfaces rollout of the tyFlow object, set the export group to something other than default (ex: ‘A’) then render…do you still see the bones?
Hmm... it doesn't seem to work - I've just tried tweaking export groups a bit, but all it does is it hides bones from viewport but not from the render. Annoying thing! lol  Huh
p.s. I have made a post on Autodesk forums about the rig showing on render. Open to suggestions in the meantime!
Yess! I have recorded the CAT rig's animation into a point cache modifier and loaded that onto a cloned mesh. Animates just fine. It's not super convenient but think it'll work. Will reply with an update later. Cheers

Edit: ok, this is odd, if I tick 'non-skin deformations' for the point cached character, it will animate but it will not render. If I untick it, it will render but not animate....
Edit2: added a shape operator and it now animates and renders as expected.. however, it now creates an extra mesh in the spot - what could be wrong? https://i.imgur.com/qXTdeYQ.png
Edit3: it seems to be the position icon that creates the duplicate mesh. This one animates and shows in viewport. It doesn't render. Shape on the other hand, does animate and shows in viewport and render. When I deactivate the position icon operator, the faulty mesh goes to scene center, and the shape mesh stays put. The weird thing is that when I deactivate position icon operator, the faulty mesh now renders and animates at the center of the scene.
Sorry for the spam. I cannot figure out what I'm doing wrong. I am following this guide: https://www.youtube.com/watch?v=utLAEt_NmjU

At Tyflow 1, I have set up a birth -> shape (point cached model) with animated geometry enabled. This renders and animates. https://i.imgur.com/Bb2JVnw.png
At Tyflow 2, I have set up a Birth objects with Tyflow 1 as birth -> Cloth bind -> Particle switch -> Object bind (binding to Tyflow 1). This doesn't render or animate. https://i.imgur.com/X2VYX2p.png
When I select Tyflow 1 as Tyflow 2's birth object, it doesn't display in viewport nor render... I'm using Shape instead of Actor because without Shape, the 1st one doesn't seem to render...

I'm at loss as to what to do.... really all I need is an animated character to crumble into dust in the end of its animation. I want it to animate while it's fracturing.

Hmm... it seems Arnold also doesn't render Cloth Bind... when I do a surface test using a box near the character, and send that test into a Cloth Bind "convert to shape", it then renders that part of the character, in this case the head as it's within the distance to the nearby box. Video: https://streamable.com/6yji74
Apparently.... this is also an Arnold bug. https://forum.tyflow.com/printthread.php?tid=2011

Yesss, it now renders after exporting particles and creating tycache object. Just what I needed. Using Simulation Lab's guide, I'm also able to simulate using the rigged CAT model, as the 2nd Tyflow object does something so that only the mesh is copied over. That means I don't need to record point cache. Only need to export to tycache when I need to render now.
Maybe it could be suggested on https://docs.tyflow.com/faq/rendering/ ?
Sorry, your posts are getting confusing because you have multiple concurrent threads where you're dealing with different issues you're running into, and you have many post edits where you either confirm that the issue is solved, or list new issues you've run into. It is very hard to follow what you're trying to accomplish, especially since the time I have to provide direct help on the forum here is limited. Perhaps the tyFlow Group on facebook would be a better avenue to get help with your experiments? It's a very active group with many people who are willing to give advice for tyFlow-related questions.
Thanks, and no problem. I can see how the threads are getting overwhelming. I have now resolved all of the Arnold bugs and created the result I was after.
I'm glad to hear it Smile

Forum Jump: