tyCache issues
#1
Hey there,

I´ve been trying to cache my first production sim and run into some problems with exporting through tyCache. I simulated with low resolution, once I was happy, I wanted to export to disk.

But I get several problems: 
1. Flickering frames
2. Frames being stuck, as if they are not simulated at all.

Mesh op is set to Vrayinstances, display is set to geometry and 5%, might that be an issue?

If I´m missing some setting or hitting a limitation, I´d like to know, since its a production scene it might take me a while to strip down/reproduce.


Attached Files
.mp4   Cache_Bite.mp4 (Size: 1.7 MB / Downloads: 205)
.mp4   tyCache_Bite.mp4 (Size: 4.39 MB / Downloads: 208)
  Reply
#2
Hey,

It's tough to tell what the problem is because your descriptions aren't matching what I expected to see in the video. You said flickering frames but I didn't see any missing frames or anything, maybe just some unexpected jitters in the sim. Is that what you're referring to? Also not sure why 2) is happening.

Difficult to diagnose without a scene....first thing you could try for 2) is to export to tyCache with caching disabled (tyflow object->cache rollout). If that makes a difference it will help me diagnose the bug. If you are able to strip down the scene it would be a lot easier to figure out the problem. If possible, send to support@tyflow.com.
  Reply
#3
Yeah, I figured. The flickering didn't happen in this version but I'm assuming it was there due the same issue with frames being skipped, like in this version.
Caching was already disabled in the main rollout. 
I'll try to strip down the scene, quite often the problem disappears then anyways... Smile
  Reply
#4
hey,

just letting you know that I finally figured out the problem. At some point I was playing around with the particle sleep settings, while trying to figure out how to make the initial voxelisation settle faster. Lowering the sleep settings fixed the issue with the particles being seemingly "stuck" or not reacting to forces anymore.
Not sure why this started happening during export, I´m guessing I also change the Timestep settings and it got triggered this way.
There might possibly still be an issue when exporting after having already cached part of the sim.
While exporting I disabled caching as suggested, so maybe some frames were still in memory from before.
  Reply
#5
One more thing to clarify, I´m quoting from a different thread, where you answered about the particle scale:

Quote:It can affect simulation down the flow, it all depends on what your Particle Physics collision radius value is set to. If you have it set to absolute, particle scaling won't be considered. If you have it set to scale radius, any changes to particle scale will affect the sim.

If you want particle physics collisions to conform to your meshes (whose size may be independent of scale), set the collision to shape radius instead.

My workflow would be:
1. Set display to sprite, use low res voxel to tweak sim til I´m happy.
2. Once I´m happy with the result, add shape and mesh op and set display to mesh, possibly add scale op if I use a lot of different meshes and then visually tweak the scale til I´m happy.
2b) Possibly add a second flow, use birth flow and flow update and tweak the scale and shapes settings in that flow for faster feedback.
3. Copy shape/mesh/scale op to the first flow and export cache with hires voxels.

In my current workflow I used "scale radius" set to 1 in the Particle Physics op and that got me close enough results when changing voxels from lores to high res.
But once I add shape/scale ops, the results are way off.
So how should I approach this, for a consistent result throughout all steps?

If I´m understanding this right, I´d have to use "absolut radius" and set that to about the size of the voxels (so if they are set to 0.2cm, I would use absolut radius of 0.2cm).
Is that correct?

Hm, ok, doesn´t seem to work like expected...
If I use absolut scale, I have to adjust the radius to half of what scale radius is (before adding shape/scale op).
Not sure if I understand the relationship here...

I´d guess that the voxel size describes the cubic dimensions of the voxels, while the absolute radius describes the radius of the collision spheres, so that would explain why I would have to set the absolute scale to half of that (diameter/2=radius).
I was probably just irritated because the particles filling the voxels are displayed as spheres (sprites), so I didn´t think of that relationship...

Can you confirm this?
If this is correct it might be a good idea to automatically default the absolute radius value to conform to the voxel size, if thats possible.
Or just make a note in the docs about that.
Anyways, still caching out with these settings, so I´ll probably be back in a second...Wink
  Reply


Forum Jump: