restrict lookat axis for trees on a hill
How do I have tree plane objects distributed on a hill rotate only on their local Z axis to look in the direction of a point?
Make sure you set the proper forward vector in the Rotation operator look-at settings.
I played around with it but couldn't work out which setting I should be using. My lookat object is a simple point.

"From World" set to 1.0 seems to work, but the particles are also changing position for some reason and depending on their location that leaves them half-buried in the hill.

Ok, I think I'm getting the result I wanted, but I had to rotate Z -90 in the Rotation->Orientation settings.
See attached.

Attached Files
.max   hillAlign.max (Size: 668 KB / Downloads: 7)
Thanks, I appreciate the help.
Unfortunately I'm on max 2020.
Here's a 2020 version:

Attached Files
.max   hillAlign.max (Size: 680 KB / Downloads: 5)
Thank you!
I'm getting a strange result here though. Is the attached image how it's meant to be? The trees are aligned to the surface normals, not vertical world z.

I thought you wanted them to be aligned to the surface as well.

If not just set forward axis to world (0,0,1).
Thanks. That's what I did to get the result. Although I still can't figure out why I had to rotate them -90 on Z.
I wasn't aware of the Move Pivots operator. That's really useful.

Thanks again for the help!

Forum Jump: