TyCaches not rendered when using Deadline

I have a scene that contains two TyCaches that renders fine locally, but not at all when sending scene to Deadline. 
Cache network path is visible to all machines. Even my local workstation is rendering empty scene thru deadline. The same scene rendered just fine locally.

Any ideas?

This is a bug that I discovered myself like 30 minutes ago. It exists in certain circumstances in prior versions of tyFlow but was exacerbated by a change made in v0.16015.

If you email support@tyflow.com I can send you a custom build with the fix immediately, otherwise the next version will be posted on the site sometime this weekend.

I believe a temporary workaround is to disable VRay motion blur, or set tyCache render mode to "Meshes" and put an edit_mesh modifier on top of it in the modifier stack.
Good to hear that it's already fixed. I'll wait for the next release and finetune my scene while waiting.


Still problems rendering using Deadline.
In the beginning everything goes fine, but when particle count rises, slaves will stall.
Everything is cached. Memory usage is ok (average 24GB).

Rendering locally takes under 10 minutes per frame and using deadline same frame might take an hour.

I'm sometimes getting this error in Deadline:
Error: RenderTask: Unexpected exception (vector<T> too long

Using latest tyFlow_016016_VRayNEXT on Max 2019

Try telling deadline to restart max between tasks. You can also try turning tyCache's 'keep frames in RAM' option off although that should be disabled by default when network rendering.

Is slave RAM usage the same as local usage? And do all slaves have the same version of VRay? If VRay isn't compatible or detected, tyCaches will default to mesh mode, which could definitely overload RAM with too many particles.
All machines are using same amount of ram and have same Vray version.
It's not only the slaves not rendering using deadline. Same happens with my workstation.
I have tried turning off Keep frames in RAM, which didn't help. I'll try that restart Max between tasks option also.

If it helps, I can send you a link to Max scene and caches of one frame. The whole sequence is too huge to upload.
You can send it my way, sure. Just send a google drive upload to support@tyflow.com and I'll try to replicate the problem tomorrow when I get a chance.
After further testing, I think I have found the reason.

If I turn (Display in viewport) off, slaves do render just fine. I don't know why that is affecting the rendering, but it does.
I sent two identical versions to Deadline - only difference was Display in viewport setting.

Slave machines doesn't have dedicated GPU.
That's very weird...as slaves should not trigger viewport display since they don't have viewports and shouldn't call viewport-related functions...could you confirm that your render machines do not load the max UI and are properly running in satellite/cmd mode?

Forum Jump: