How to "Find Target" go smoothly to the position?
#1
Hi everybody,

I'm only a beginner so... Wink

How can I make particles go smoothly to the "position"? I don't get it. I'm sending my file and the screenshot.


Thanks for this great plugin!
John

   
.max   Find_Target_test.max (Size: 676 KB / Downloads: 96)
  Reply
#2
In the find target operation you have "Ease In" parameter, that is there just for that. Smile
  Reply
#3
(05-29-2019, 10:06 AM)d4rk3lf Wrote: In the find target operation you have "Ease In" parameter, that is there just for that. Smile

I know, but it doesn't go "easy" as it should. Could you please try it? Thanks a lot! Wink
  Reply
#4
Is this work for you? 
3ds max 2018

ups.. attachment


Attached Files
.max   find_target_slow.max (Size: 604 KB / Downloads: 93)
  Reply
#5
(05-29-2019, 10:57 AM)d4rk3lf Wrote: Is this work for you? 
3ds max 2018

ups.. attachment

Thanks for the effort! Smile

But, I need it just like in the original scene.
First, I need particle "Boxes" to be in "PhysX" mode and then to go smoothly to the plane (perfectly aligned). I need this kind of tyflow structure for some more complicated animation.

Thanks again! Smile
  Reply
#6
I don't have time to play right now with it. 
But my first thought's are: 
If you want perfect alignment, and perfect position, I would make basically 2 particles system, where one is on the final position, and the other is on the starting position. They must be the same number. 
Then you save position with "custom properties" operator the first particles (final position). 
And you load that position with same operator (custom properties) for the second particles. 
They should go to the final position, and you can make them smooth out with "interpolation" parameter inside "custom operator" (the one that is loaded (on second particles). 

At least in theory Smile

Check out the sample files: 
In the fracture folder, there is a "face fracture" scene, where it does exactly what I described above (though, they are not moving, just rotating... but it's the same principle...)
  Reply
#7
(05-29-2019, 11:46 AM)d4rk3lf Wrote: I don't have time to play right now with it. 
But my first thought's are: 
If you want perfect alignment, and perfect position, I would make basically 2 particles system, where one is on the final position, and the other is on the starting position. They must be the same number. 
Then you save position with "custom properties" operator the first particles (final position). 
And you load that position with same operator (custom properties) for the second particles. 
They should go to the final position, and you can make them smooth out with "interpolation" parameter inside "custom operator" (the one that is loaded (on second particles). 

At least in theory Smile

Check out the sample files: 
In the fracture folder, there is a "face fracture" scene, where it does exactly what I described above (though, they are not moving, just rotating... but it's the same principle...)

Thanks a lot! Will try it! Smile

...but if I don't make it, I'll be back hehe  Cool
  Reply
#8
I'm back Rolleyes

Noup... it's not working for me.

I don't know if this is possible or not. Please see the attachments. I tried with custom properties but it's not working.

Is this a BUG or I don't know how to use it, but it should be a very simple task:

1. boxes are in perfect alignment (3x3)
2. boxes falls down (PhysX)
3. boxes are back in perfect alignment (start position)


Please anyone, if you know how can this be done, please help me...

Thank you Smile


.max   Find_Target_Test2.max (Size: 704 KB / Downloads: 96)    
  Reply
#9
particle born use property set the tm data,
then you can use property load data,the tyflow sence simple file have this,the same to your sence
  Reply
#10
(06-01-2019, 02:58 PM)lmw17009 Wrote: particle born use property set the tm data,
then you can use property load data,the tyflow sence simple file have this,the same to your sence

Thanks!

I know about TM data and how it works, but the thing is that if I add PhysX it doesn't work as it should, and even if I switch it off (PhysX), it still doesn't work.
It works only without the PhysX. I have reported it as a bug and tyFlow said it might be a bug.

Could you please let me know where is that "tyflow sence simple file"? What is the name of the file?

Thanks a lot! Smile
  Reply
#11
I just did it. 
Here's the video: 
https://youtu.be/QoZMt5Ei0Pc

In the attachment are files for max 2017 and 2018. 

Notice the changes I made in the "custom properties" (the last one, in the last event), and I changed timing to "continuous", and interpolation to 0,1 (so it's smooth). 
Maybe that was "bugging" you.


Attached Files
.zip   boxes_2017.zip (Size: 78.21 KB / Downloads: 109)
  Reply
#12
(06-02-2019, 11:25 AM)d4rk3lf Wrote: I just did it. 
Here's the video: 
https://youtu.be/QoZMt5Ei0Pc

In the attachment are files for max 2017 and 2018. 

Notice the changes I made in the "custom properties" (the last one, in the last event), and I changed timing to "continuous", and interpolation to 0,1 (so it's smooth). 
Maybe that was "bugging" you.

I love you brother, you've even upload it on youtube Big Grin  thank you very much!

But... I have to be honest with you. As I said, I need this for much complex scene. This boxes are going to be 100s small screens that are going to create a grid of display, so it just has to be perfectly aligned. You can see that your boxes are pretty close but it's not perfectly. I already reported this as a bug and tyFlow assumes that it could be a bug. It's probably the PhysX.

So, I just continued working without PhysX, and it works perfectly.

Thank you so much for helping me!  Smile     

   
  Reply
#13
Oh... I see... 
If you turn off "spin random" operator in my scene, they should be back in perfect position (I just tested it). 
I gave it spin random, only so I make it visually more interesting. 
If you want spin to be there, then you can try saving the rotation parameter in custom properties, and load them back. 

As for the Physx... maybe it's bug... bot notice this. 
Physics by default have gravity that constantly pulls particle down, and you can't expect to work perfectly, because you need to add a force that will fight will gravity all the time. 
I just animated gravity in Physics (select tyflow icon, and go to modify panel to find it) so it's zero after the boxes fall down - and it's working Smile
  Reply
#14
(06-02-2019, 01:05 PM)d4rk3lf Wrote: Oh... I see... 
If you turn off "spin random" operator in my scene, they should be back in perfect position (I just tested it). 
I gave it spin random, only so I make it visually more interesting. 
If you want spin to be there, then you can try saving the rotation parameter in custom properties, and load them back. 

As for the Physx... maybe it's bug... bot notice this. 
Physics by default have gravity that constantly pulls particle down, and you can't expect to work perfectly, because you need to add a force that will fight will gravity all the time. 
I just animated gravity in Physics (select tyflow icon, and go to modify panel to find it) so it's zero after the boxes fall down - and it's working Smile

Thank you very much!!! Big Grin
  Reply
#15
I was stuck in property before, just change the parameter to continue. I think you've done it, haha.
  Reply
#16
(06-03-2019, 12:25 PM)lmw17009 Wrote: I was stuck in property before, just change the parameter to continue. I think you've done it, haha.

Yes! Big Grin

Thanks for the help!
  Reply
#17
(05-29-2019, 10:57 AM)d4rk3lf Wrote: Is this work for you? 
3ds max 2018

ups.. attachment

Just a quick headsup - I just tried loading the scene and it's infected with a 3dsmax virus fyi!
  Reply
#18
(11-21-2020, 04:56 PM)Martians Wrote: Just a quick headsup - I just tried loading the scene and it's infected with a 3dsmax virus fyi!

This was a very old upload, and I might have been infected by that time (also by downloading someone's else scenes - lol Smile   ). 
Just download Security Tools for Autodesk. 


This way 3DS Max will recognize every faulty file, and it won't harm your app, and you can just delete these 2 objects. 
(to tell you the truth, even when I was "infected", I never noticed anything wrong with the scenes). 
  Reply


Forum Jump: